Zyte API - Performance degradation
Incident Report for Zyte
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 12:05 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2024 - 08:07 UTC
Update
Our tech team has ruled out any application-level causes for the recent service degradation. Based on our ongoing investigation, the issue appears to be linked to changes made by our PaaS provider to the Kubernetes control plane, which affected pod discovery and led to increased latency and timeouts.

While we continue to validate this theory and work closely with the PaaS provider, we have also taken immediate steps to mitigate the performance issues. We have transitioned to a new cluster that is not impacted by the affected components.

We expect services to return to normal over the course of today.
Posted Sep 11, 2024 - 04:11 UTC
Investigating
We are observing a degradation of performance for rendered requests in ZyteAPI. A subset of requests involving browser rendering are currently receiving errors and we are actively working on resolving this issue.
Posted Sep 10, 2024 - 03:27 UTC
This incident affected: Zyte API (Zyte API).